Net.Pipe and Net.Tcp Service not starting after in-place upgrade to Server 2012R2

Having just performed an in-place upgrade from Server 2008R2 to 2012R2 on two of our DHCP servers, I noticed the following two errors in Server Manager once the upgrade was complete:

Before hotfix
When Clicking on the Services link I was presented with the information that Net.Tcp Listener Adapter and the Net.Pipe Listener Adapter services could not be started.

When I checked the services it could clearly be seen that they were set to automatic but had not started.  Manually trying to start the services would not work either.
Services before hotfix

The solution was in two parts.  The first was to fully patch the server – on checking I found the server had 41 updates required.

Once I had patched and restarted the server, I only had one error in Server Manager:
a - After Patching
The only error now was showing that the Net.Tcp Listener Adapter service was in a stopped status:
b - After Patching

When I tried to start it manually I received the following error:
c - Error when trying to start manually

I checked the Event log and found the following information:
d - System Event log explains why

Cool – now we’re getting somewhere.. I needed to start the Net.Tcp Port Sharing Service.  When I checked, it was indeed disabled.
I set it to automatic:
e - change service to automatic

Once that was done, I attempted to start the Net.Tcp Listener Adapter service again:
f - start the listener tcp adapter

Success!
g - Server Manager Results

3 Comments

Leave a Reply

Your email address will not be published.


*