Task sequence error 0x00004005 when using USMT

Here’s a strange one that took me a while to figure out.  I was incorporating USMT into a new task sequence and it kept failing right at the start of the USMT section: ‘Request State Store’ where it would hang for a couple of minutes until it timed out and presented me with the error: 0x00004005

USMTerror

I checked the smsts.log on the client computer and could see where it had tried the computer account and failed on credentials (as expected), and then said that it was about to try the Network Access account.  When it did so, it showed the error: ‘Cannot connect to http://servername SMP root share.‘  No mention of credentials being wrong.

What’s more, to contradict that error, I could manually connect to the SMP share that the log was whining about using the Network Access Account.

I had tried resetting the Network Access account password, removing the SMP role and adding it back, rebooting the server and the perusal of several log files as well as trying drastic things out such as giving excessive permissions to the Network access account just to rule it out.  Even Google couldn’t help me.

The solution – and it took a while for me to figure this one out, was that I was trying this all out in Hyper-V.  It suddenly dawned on me that I had not tried to run the task sequence on a real ie physical computer and as soon as I did –  bingo!  Success!

1 Comment

  1. I will try to remember to return and thank you if this works tomorrow. I’ve been banging my head and did everything you described. I’ll try physical tomorrow.

Leave a Reply

Your email address will not be published.


*